Scheduled Maintenance for general stability and performance improvements
Incident Report for Linode
Resolved
We have successfully completed maintenance for general stability and performance improvements. If you have any questions regarding this, please reach out to our Support team.
Posted Aug 10, 2020 - 23:09 UTC
Identified
We have identified and developed a number of critical stability and performance improvements for our infrastructure. These include fixes for a potential crash, general performance tweaks, and enhancements to networking throughput. After implementing, testing, deploying, and gaining confidence in these changes, we are now ready to roll updates out to the remaining fleet. This is expected to significantly decrease the amount of unplanned maintenance.

To complete this, we will be performing reboots on a subset of Linode’s host machines. This maintenance will update the underlying infrastructure that Linodes reside on and will not affect the data stored within them.

If you are on an affected host, your maintenance window will be communicated to you via a Support ticket within the next few days. You can prepare your Linode for this maintenance by following our Reboot Survival Guide.

During the actual maintenance window, your Linode will be cleanly shut down and will be unavailable while we perform the updates. To minimize impact, maintenance will be limited to each respective datacenter’s local off-hours time. A 2-hour window is allocated, however the actual downtime should be around 45-60 minutes. After the maintenance has concluded, each Linode will be returned to its last state (running or powered off).

This status page will be updated once maintenance is complete.
Posted Jul 16, 2020 - 14:18 UTC
This incident affected: Regions (US-East (Newark), US-Central (Dallas), US-West (Fremont), US-Southeast (Atlanta), EU-West (London), EU-Central (Frankfurt), AP-South (Singapore), AP-Northeast-2 (Tokyo 2)).