Service Issue - Linode Kubernetes Engine
Incident Report for Linode
Postmortem

On June 15, 2022 at ~18:30 UTC, an incremental update was pushed to the production environment for LKE. This update was missing changes from the previous release, resulting in silent failures for customers attempting to upgrade clusters or add nodes. This was resolved by adding the missing changes to a subsequent update to the service. The update was released at ~21:00 UTC and resolved this issue. To prevent similar issues in the future, additional steps and automation for updates have been put in place.

Posted Jun 22, 2022 - 18:56 UTC

Resolved
We haven’t observed any additional issues with the LKE service, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Jun 16, 2022 - 00:31 UTC
Monitoring
At this time we have been able to correct the issues affecting the LKE service. We will be monitoring this to ensure that it remains stable. If you continue to experience problems, please open a Support ticket for assistance.
Posted Jun 15, 2022 - 21:09 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 15, 2022 - 20:26 UTC
Investigating
Our team is investigating an issue affecting the Linode Kubernetes Engine (LKE). We will share additional updates as we have more information.
Posted Jun 15, 2022 - 19:54 UTC
This incident affected: Linode Kubernetes Engine (US-East (Newark) Linode Kubernetes Engine, US-Central (Dallas) Linode Kubernetes Engine, US-West (Fremont) Linode Kubernetes Engine, CA-Central (Toronto) Linode Kubernetes Engine, EU-West (London) Linode Kubernetes Engine, EU-Central (Frankfurt) Linode Kubernetes Engine, AP-South (Singapore) Linode Kubernetes Engine, AP-Northeast-2 (Tokyo 2) Linode Kubernetes Engine, AP-West (Mumbai) Linode Kubernetes Engine, AP-Southeast (Sydney) Linode Kubernetes Engine, US-Southeast (Atlanta) Linode Kubernetes Engine).