Update
Our subject matter experts are continuing to work on mitigating the impact. The efforts for Object Storage E2/E3 endpoints from Melbourne are completed. For the remaining Object Storage E2/E3 endpoints, the mitigation efforts are ongoing and will require additional time to fully resolve the issue. We appreciate your patience and will provide further updates as progress continues.
If you have any questions, please contact our support team at support@linode.com or call us at +1-855-454-6633 (US) or +1-609-380-7100 (Global) for assistance.
Posted Jul 19, 2025 - 03:27 UTC
Update
Our subject matter experts are continuing to work on mitigating the impact. The efforts for Object Storage E2/E3 endpoints from Melbourne are completed. For the remaining Object Storage E2/E3 endpoints, the mitigation efforts are ongoing and will require additional time to fully resolve the issue. We appreciate your patience and will provide further updates as progress continues.
If you have any questions, please contact our support team at support@linode.com or call us at +1-855-454-6633 (US) or +1-609-380-7100 (Global) for assistance.
Posted Jul 19, 2025 - 00:05 UTC
Update
Our subject matter experts are continuing to work on mitigating the impact. The Linode Kubernetes Engine (LKE) service has been largely restored, and we continue to work on mitigating the impact in the London and Chicago regions. Mitigation efforts for Object Storage E2/E3 endpoints are ongoing and will require additional time to fully resolve the issue. We appreciate your patience and will provide further updates as progress continues.
Posted Jul 18, 2025 - 18:43 UTC
Update
We are continuing to work on mitigating the impact of this incident. The Linode Kubernetes Engine (LKE) service has been largely restored and is operating normally for most customers. Mitigation efforts for Object Storage E2/E3 endpoints are ongoing and will require additional time to fully resolve. We appreciate your patience and will provide further updates as progress continues.
Posted Jul 18, 2025 - 14:10 UTC
Update
Our subject matter experts are actively working on the recovery of the impacted Object Storage E2/E3 endpoints. We will share further updates as we make progress. We apologize for the impact and thank you for your patience and continued support. If you have any questions, please contact our support team at support@linode.com or call us at +1-855-454-6633 (US) or +1-609-380-7100 (Global) for assistance.
Posted Jul 18, 2025 - 09:20 UTC
Update
Current Status
Our teams are actively working to resolve issues impacting Object Storage E2 and E3 endpoints. While Standard (E0/E1) endpoints were not affected, we are working on system recovery for all E2 and E3 endpoints. These issues are being prioritized, and expert teams are engaged in resolving the impact.
Object Storage E2 and E3 Endpoint Recovery Plan
We are employing an incremental approach to ensure a safe and methodical recovery.
> Recovery order by Datacenter: We understand that you may have questions about the recovery process for your specific region. At this time, we are taking a step-by-step approach, and as a result, we do not yet have a determined order for datacenter recovery. Our focus is on restoring systems safely, working to minimize impact across all customers. We will share updates regularly as recovery progresses and will notify you promptly once we can confirm timelines for your specific E2/E3 Endpoint region(s).
> Testing and Validation: To ensure stability and avoid service disruptions, all systems will undergo extensive testing prior to resuming regular operations.
Impact and Timelines
While we are devoting 24/7 engineering resources to this recovery operation, complete resolution will depend on the results of our ongoing diagnostics. Full recovery for affected regions may require multiple days and our teams are looking for ways to optimize and parallelize recovery operations. As we make further progress over the next few hours, we expect to be able to provide more specific updates on estimated recovery times.
Our Commitment
We deeply regret the impact being caused by this disruption and want to assure you of our commitment to restoring full operations as quickly and safely as possible. We will keep you updated with progress and key milestones throughout the recovery process. If you have any questions or concerns, please do not hesitate to reach out to our support team at support@linode.com or call us at +1-855-454-6633 (US) or +1-609-380-7100 (Global) for assistance.
Posted Jul 18, 2025 - 02:39 UTC
Identified
Affected services have begun to come back online. Currently, the following services are up:
• Creating and restoring images to Linodes
• LKE and LKE-Enterprise new cluster provisioning, except in London
• Managed Databases
We are working to restore service to all affected Object Storage E2 and E3 endpoints and will continue to provide updates as more services come back online.
Posted Jul 18, 2025 - 01:06 UTC
Update
We are continuing to investigate this issue. The appropriate subject matter experts are engaged. We will continue to provide hourly updates until we have a clearer picture about the mitigation plan. Subsequent updates around mitigation status will be posted as progress is made.
Posted Jul 17, 2025 - 23:43 UTC
Update
We have confirmed that the issue is impacting the following services:
• Object Storage Key and bucket management using the Linode Cloud Manager and Linode APIv4
• The following Object Storage E2 and E3 endpoints are down:
• jp-osa-1.linodeobjects.com
• us-sea-9.linodeobjects.com
• au-mel-1.linodeobjects.com
• gb-lon-1.linodeobjects.com
• in-bom-1.linodeobjects.com
• jp-tyo-1.linodeobjects.com
• us-iad-13.linodeobjects.com
• us-ord-10.linodeobjects.com
• de-fra-1.linodeobjects.com
• sg-sin-1.linodeobjects.com
• Linode Kubernetes Engine (LKE) and LKE-Enterprise
• Creating clusters
• Restoring clusters from a backup
• Creating and restoring images, including deployment of Linodes from images
• Managed Databases
• Provisioning new clusters
• Resizing existing clusters
• Resuming a suspended cluster
• Restoring existing clusters from backup
• Multi-node clusters will be able to recover from a primary node failure automatically as long as cluster standby Linodes are online
• Automatic recreation of failed nodes is unavailable at this time
We will continue to share updates as we have more information.
Posted Jul 17, 2025 - 22:32 UTC
Investigating
Our team is investigating an emerging service issue affecting LKE and Object Storage in all regions. We will share additional updates as we have more information.
Posted Jul 17, 2025 - 20:35 UTC
This incident affects: Object Storage (US-East (Newark) Object Storage, US-Southeast (Atlanta) Object Storage, US-IAD (Washington) Object Storage, US-ORD (Chicago) Object Storage, EU-Central (Frankfurt) Object Storage, AP-South (Singapore) Object Storage, FR-PAR (Paris) Object Storage, SE-STO (Stockholm) Object Storage, US-SEA (Seattle) Object Storage, JP-OSA (Osaka) Object Storage, IN-MAA (Chennai) Object Storage, ID-CGK (Jakarta) Object Storage, BR-GRU (Sao Paulo) Object Storage, ES-MAD (Madrid) Object Storage, GB-LON (London 2), AU-MEL (Melbourne), NL-AMS (Amsterdam) Object Storage, IT-MIL (Milan) Object Storage, US-MIA (Miami) Object Storage, US-LAX (Los Angeles) Object Storage, GB-LON (London 2) Object Storage, AU-MEL (Melbourne) Object Storage, IN-BOM-2 (Mumbai 2) Object Storage, DE-FRA-2 (Frankfurt 2) Object Storage, SG-SIN-2 (Singapore 2) Object Storage, JP-TYO-3 (Tokyo 3) Object Storage) and Linode Kubernetes Engine (US-East (Newark) Linode Kubernetes Engine, US-Central (Dallas) Linode Kubernetes Engine, US-West (Fremont) Linode Kubernetes Engine, US-Southeast (Atlanta) Linode Kubernetes Engine, US-IAD (Washington) Linode Kubernetes Engine, US-ORD (Chicago) Linode Kubernetes Engine, CA-Central (Toronto) Linode Kubernetes Engine, EU-West (London) Linode Kubernetes Engine, EU-Central (Frankfurt) Linode Kubernetes Engine, FR-PAR (Paris) Linode Kubernetes Engine, AP-South (Singapore) Linode Kubernetes Engine, AP-Northeast-2 (Tokyo 2) Linode Kubernetes Engine, AP-West (Mumbai) Linode Kubernetes Engine, AP-Southeast (Sydney) Linode Kubernetes Engine, SE-STO (Stockholm) Linode Kubernetes Engine, US-SEA (Seattle) Linode Kubernetes Engine, JP-OSA (Osaka) Linode Kubernetes Engine, IN-MAA (Chennai) Linode Kubernetes Engine, ID-CGK (Jakarta) Linode Kubernetes Engine, BR-GRU (São Paulo) Linode Kubernetes Engine, NL-AMS (Amsterdam) Linode Kubernetes Engine, ES-MAD (Madrid) Linode Kubernetes Engine, IT-MIL (Milan) Linode Kubernetes Engine, US-MIA (Miami) Linode Kubernetes Engine, US-LAX (Los Angeles) Linode Kubernetes Engine, GB-LON (London 2) Linode Kubernetes Engine, AU-MEL (Melbourne) Linode Kubernetes Engine, IN-BOM-2 (Mumbai 2) Linode Kubernetes Engine, DE-FRA-2 (Frankfurt 2) Linode Kubernetes Engine, SG-SIN-2 (Singapore 2) Linode Kubernetes Engine, JP-TYO-3 (Tokyo 3) Linode Kubernetes Engine).