Emerging Service Issue - Node Balancers - All Regions

Incident Report for Linode

Resolved

We haven’t observed any additional issues with the Node Balancers, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Mar 28, 2025 - 09:05 UTC

Monitoring

At this time we have been able to correct the issues affecting the NodeBalancer service. We will be monitoring this to ensure that it remains stable. If you continue to experience problems, please open a ticket with our Support Team.
Posted Mar 28, 2025 - 05:56 UTC

Update

We are continuing to investigate this issue.
Posted Mar 28, 2025 - 01:07 UTC

Update

We are continuing to investigate this issue.
Posted Mar 27, 2025 - 23:45 UTC

Investigating

Our team is investigating an emerging service issue affecting Node Balancers in all regions. We will share additional updates as we have more information.
Posted Mar 27, 2025 - 22:57 UTC
This incident affected: NodeBalancers (US-East (Newark) NodeBalancers, US-Central (Dallas) NodeBalancers, US-West (Fremont) NodeBalancers, US-Southeast (Atlanta) NodeBalancers, US-IAD (Washington) NodeBalancers, US-ORD (Chicago) NodeBalancers, CA-Central (Toronto) NodeBalancers, EU-West (London) NodeBalancers, EU-Central (Frankfurt) NodeBalancers, FR-PAR (Paris) NodeBalancers, AP-South (Singapore) NodeBalancers, AP-Northeast-2 (Tokyo 2) NodeBalancers, AP-West (Mumbai) NodeBalancers, AP-Southeast (Sydney) NodeBalancers, SE-STO (Stockholm) NodeBalancers, US-SEA (Seattle) NodeBalancers, JP-OSA (Osaka) NodeBalancers, IN-MAA (Chennai) NodeBalancers).