Connectivity Issues - US-MIA (Miami) , IT-MIL (Milan) and BR- GRU (Sao Paulo)

Incident Report for Linode

Postmortem

Customers may have experienced brief performance issues if they were using the data centers US-MIA (Miami) and IT-MIL (Milan) on September 14, 2025, between 17:42 UTC and 18:43 UTC or data center BR-GRU (Sao Paulo) on September 15, 2025 between 01:44 UTC and 04:22 UTC by packet loss. Impact would vary depending on the nature of what products/services customers were connected to during those times, but in the majority of the cases, customers observed performance degradation.

The issue was triggered when routing thresholds between our core router and edge router exceeded the maximum number of permitted prefixes.. When these limits were reached, the traffic from the Datacenters shifted to alternate paths, which resulted in network congestion and subsequently led to the observed packet loss. The issue was then initiated by a gradual increase that triggered this safety limit. We have not identified any ISP issues which may have contributed to this situation. 

In order to mitigate the issue, Akamai has increased the prefix limit on all the Datacenter Routers.

To prevent a recurrence, Akamai will:

  • Work towards increasing the thresholds sessions between Akamai’s Backbone and Datacenter ECOR Routers
  • Improve existing alerting and validate the severity prior to limits being reached. These alerts will then be escalated internally to the appropriate team for immediate corrective action.

This summary provides an overview of our current understanding of the incident given the information available. Our investigation is ongoing and any information herein is subject to change.

Posted Sep 17, 2025 - 17:45 UTC

Resolved

We haven’t observed any additional connectivity issues in any of the data centers, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Sep 16, 2025 - 16:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results. Subsequent updates around mitigation status will be posted as progress is made.
Posted Sep 15, 2025 - 08:20 UTC

Investigating

While Miami, US, IT data centers are operational, we are observing issues in Sao Paulo Brazil and our team is investigating. During this time, users may experience high packet loss for all services deployed in this data center. We will share additional updates as we have more information.
Posted Sep 15, 2025 - 03:32 UTC

Update

We are continuing to monitor our systems, as of this hour there are no recurrences of this issue. The appropriate subject matter experts are engaged. Subsequent updates around mitigation status will be posted as progress is made.
Posted Sep 15, 2025 - 00:31 UTC

Monitoring

At this time we can confirm the issues affecting connectivity in our Miami, US and Milan, IT data center are no longer impacting our services. We can confirm the issue lasted from 17:42 UTC to 18:43 UTC on September 14th, 2025. We will be monitoring this to ensure that it remains stable. If you are still experiencing issues, please open a Support ticket for assistance.
Posted Sep 14, 2025 - 20:10 UTC

Update

We are continuing to investigate this issue.
Posted Sep 14, 2025 - 19:05 UTC

Investigating

Our team is investigating an issue affecting connectivity in our Miami, US and Milan, IT data center. During this time, users may experience high packet loss for all services deployed in these data centers. We will share additional updates as we have more information.
Posted Sep 14, 2025 - 18:54 UTC
This incident affected: Regions (IT-MIL (Milan), BR-GRU (São Paulo), US-MIA (Miami)).