Service Issue - Backups not visible in Cloud Manager

Incident Report for Linode

Postmortem

Starting on November 19, 2025, at approximately 03:39 UTC, a limited number of customers were unable to see their Backups on Cloud Manager. The issue was caused by a planned Cloud Identity and Access Management configuration change that aimed at adding some customers to a Role-Based Access Control (RBAC), and did not impact the integrity of the backups.

The root cause was identified at approximately 10:00 UTC, and the change was successfully rolled back at 10:42 UTC, at which point the impact was mitigated.

To prevent a recurrence, Akamai will review the relevant change procedures to identify potential gaps and make the necessary changes.

This summary provides an overview of our current understanding of the incident, given the information available. Our investigation is ongoing, and any information herein is subject to change.

Posted Nov 19, 2025 - 13:02 UTC

Resolved

We haven't observed any additional issues with the Backups in Cloud Manager, and will now consider this incident resolved. If you continue to experience issues, please contact us at 855-454-6633 (+1-609-380-7100 Intl.), or send an email to support@linode.com for assistance.
Posted Nov 19, 2025 - 12:03 UTC

Identified

Our team has identified the issue affecting the Backup visibility in Cloud Manager. We are working quickly to implement a fix, and we will provide an update as soon as the solution is in place.
Posted Nov 19, 2025 - 11:29 UTC

Update

We are continuing to investigate an issue where backups are not visible in Cloud Manager. Please note that the backups are not impacted, the issue only affects the visibility. We will share additional updates as we have more information.
Posted Nov 19, 2025 - 10:17 UTC

Investigating

Our team is investigating an emerging service issue where backups are not visible in Cloud Manager. We will share additional updates as we have more information.
Posted Nov 19, 2025 - 08:54 UTC
This incident affected: Linode Manager and API.