Service Issue - Linode Kubernetes Engine

Incident Report for Linode

Resolved

We haven’t observed any additional issues with the LKE service, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Apr 03, 2025 - 01:09 UTC

Monitoring

At this time we have been able to correct the issues affecting the LKE service. We will be monitoring this to ensure that it remains stable. If you continue to experience problems, please open a Support ticket for assistance.
Posted Apr 01, 2025 - 23:03 UTC

Identified

Our team has identified the underlying cause of the issue affecting DNS functionality within the Linode Kubernetes Engine (LKE) service. We are in the process of implementing a fix. Users may have experienced difficulty connecting to their cluster's control plane, but internal cluster services remain unaffected at this time.

We will continue to provide updates as we work to fully resolve the issue. Thank you for your patience.
Posted Apr 01, 2025 - 22:29 UTC

Update

Our team is actively investigating an issue impacting DNS functionality within the Linode Kubernetes Engine (LKE) service. We will provide further updates as more information becomes available.
Posted Apr 01, 2025 - 21:33 UTC

Investigating

Our team is investigating an issue affecting the Linode Kubernetes Engine (LKE). During this time users may have difficulty connecting to their cluster control plane. Internal cluster services are not impacted at this time. We will share additional updates as we have more information.
Posted Apr 01, 2025 - 20:28 UTC
This incident affected: Linode Kubernetes Engine (US-East (Newark) Linode Kubernetes Engine, US-Central (Dallas) Linode Kubernetes Engine, US-West (Fremont) Linode Kubernetes Engine, US-Southeast (Atlanta) Linode Kubernetes Engine, US-IAD (Washington) Linode Kubernetes Engine, US-ORD (Chicago) Linode Kubernetes Engine, CA-Central (Toronto) Linode Kubernetes Engine, EU-West (London) Linode Kubernetes Engine, EU-Central (Frankfurt) Linode Kubernetes Engine, FR-PAR (Paris) Linode Kubernetes Engine, AP-South (Singapore) Linode Kubernetes Engine, AP-Northeast-2 (Tokyo 2) Linode Kubernetes Engine, AP-West (Mumbai) Linode Kubernetes Engine, AP-Southeast (Sydney) Linode Kubernetes Engine, SE-STO (Stockholm) Linode Kubernetes Engine, US-SEA (Seattle) Linode Kubernetes Engine, JP-OSA (Osaka) Linode Kubernetes Engine, IN-MAA (Chennai) Linode Kubernetes Engine, ID-CGK (Jakarta)).