At this time 21:45 UTC September 21st, 2026 we have been able to correct the issue affecting our DNS service in the London 1 (EU-West) region. We will be monitoring this to ensure that connectivity remains stable. Customers can apply this fix by enabling Network Helper (https://techdocs.akamai.com/cloud-computing/docs/automatically-configure-networking) and rebooting the effected Linode or please open a ticket with our Support Team.
Posted Sep 21, 2026 - 22:06 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 21, 2026 - 21:15 UTC
Update
We are continuing to work on a fix for this issue.
Posted Sep 21, 2026 - 20:07 UTC
Identified
Our team has identified the issue affecting our DNS service in the London 1 (EU-West) region. We are working quickly to implement a fix, and we will provide an update as soon as the solution is in place.
Posted Sep 21, 2026 - 18:41 UTC
Investigating
Our team is investigating an emerging service issue affecting our DNS service in the London 1 (EU-West) region. We will share additional updates as we have more information.