Service Issue - rDNS
Incident Report for Linode
Postmortem

On May 18th at 11:31 UTC we observed an issue with our Hosted rDNS Service that was preventing all newly published rDNS (PTR) records from propagating.   

Our network operations team identified an improper configuration within the software that backs our Hosted rDNS service.  This misconfiguration was preventing the updated records from being distributed as expected.

Following the implementation of a fix at 17:04 UTC rDNS (PTR) records began propagating as expected, resolving this issue.

Following the resolution, we are continuing to explore additional monitoring and alerting solutions to better prevent the recurrence of issues such as this.

Posted Jun 01, 2023 - 14:51 UTC

Resolved
We haven’t observed any additional issues with our Hosted rDNS Service, and will now consider this incident resolved. If you are still experiencing issues, please open a Support ticket for assistance.
Posted May 18, 2023 - 18:59 UTC
Monitoring
At this time we have been able to correct the issue affecting our Hosted rDNS Service. We will be monitoring this to ensure that connectivity remains stable. If you continue to experience problems, please open a ticket with our Support Team.
Posted May 18, 2023 - 17:04 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 18, 2023 - 14:23 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 18, 2023 - 12:44 UTC
Identified
We have identified an issue impacting new rDNS record propagation. Customers may experience a delay in propagation of rDNS (PTR) records that have been recently updated via Cloud Manager and our API. We will provide further updates once a solution is in place.
Posted May 18, 2023 - 11:31 UTC
This incident affected: Hosted DNS Service.