Connectivity Issue - Jakarta, ID (id-cgk)

Incident Report for Linode

Postmortem

On March 20, 2026, at approximately 10:40 UTC, the Jakarta, ID (id-cgk) data center experienced power fluctuations that caused outages across all services in Jakarta, with downstream impacts to services in the Singapore Expansion, SP (sg-sin-2), and Melbourne, AU (au-mel) regions. The facility switched to backup power, which triggered a simultaneous reboot of all data center network equipment and machines. Although switching to generator power should not have caused disruption, unexpected issues with the uninterrupted power supplies (UPS) led to outages. The data center’s facilities engineering team has identified that a transient under-voltage condition (voltage flicker) occurred on the utility power sources of our third-party data center. During this event, two of the data center’s UPS systems did not respond as designed, resulting in a power outage for the affected racks. The local data center team engaged a manual bypass of the affected UPS systems to generator power. Once utility power stabilized, the site transitioned off generator power and is now working with the UPS system vendor for further analysis. Content Delivery services experienced some performance degradation but recovered by 11:10 UTC. By 12:00 UTC, physical compute hosts were gradually becoming operational, but many Linode instances remained unavailable, resulting in service interruptions for workloads hosted in Jakarta. Ongoing reliance on backup power led to intermittent performance issues until full restoration.

Customers in the Singapore Expansion, SP (sg-sin-2), and Melbourne, AU (au-mel) regions reported issues with Linode Kubernetes Engine (LKE) and Object Storage deployments. Investigation revealed that Object Storage and LKE were impacted in the cgk1, sin2, and mel1 regions, affecting the deployment of new clusters, nodes, and node pools.

The incident was initially traced to under-voltage on the data center’s power sources. Akamai teams prioritized restoring data center networking, followed by Akamai products and services operating in Jakarta, ID. The data center returned to grid power at approximately 13:20 UTC. All services were restored, and the incident transitioned to monitoring at 17:28 UTC. Teams closely monitored all products and services in the affected data center and assessed the likelihood of another power event. With no issues identified, the incident was considered fully resolved at 18:27 UTC.

Efforts are ongoing to address dependencies between services and data centers to improve resilience and prevent recurrences. The data center is also working with their UPS system vendor to further analyze the UPS response during the event. We are committed to making continuous improvements to our systems to prevent similar incidents in the future. We apologize for the impact and thank you for your patience and continued support.

This summary provides an overview of our current understanding of the incident given the information available. Our investigation is ongoing and any information herein is subject to change.

Posted Mar 25, 2026 - 15:50 UTC

Resolved

We haven’t observed any additional connectivity issues in our Jakarta, ID (id-cgk) data center, and will now consider this incident resolved. If you continue to experience problems, please open a Support ticket for assistance.
Posted Mar 24, 2026 - 13:46 UTC

Monitoring

At this time we have been able to correct the issues affecting connectivity in our Jakarta, ID data center. We will be monitoring this to ensure that it remains stable. If you are still experiencing issues, please open a Support ticket for assistance.
Posted Mar 20, 2026 - 17:28 UTC

Update

We are continuing to work on resolving the connectivity issue in our Jakarta, ID (id-cgk) data center. Thank you for your patience as we restore full service.
Posted Mar 20, 2026 - 16:58 UTC

Update

We are making steady progress toward full recovery of the connectivity issue at our Jakarta, ID (id-cgk) data center. Most services in Jakarta are now operational. However, some Linodes and Linode Kubernetes Engine (LKE) clusters may still be affected, especially if nodes are provisioned or attempt to provision on impacted Linodes. The dependency issues that previously affected Singapore Expansion, SP (sg-sin-2) and Melbourne, AU (au-mel) have been resolved.

We continue to work on restoring all services and appreciate your patience as we address the remaining issues. Further updates will be provided as progress continues.
Posted Mar 20, 2026 - 16:07 UTC

Update

Our teams are continuing to mitigate the connectivity issue in Jakarta, ID and are working to restore full service. We appreciate your patience as we resolve the remaining disruptions.
Posted Mar 20, 2026 - 15:13 UTC

Update

We are continuing to address the connectivity issue at our Jakarta, ID (id-cgk) data center. Most services have recovered, but some compute services in Jakarta remain affected. Due to backend dependencies, customers in the Singapore Expansion, SP (sg-sin-2) and Melbourne, AU (au-mel) data centers may also experience disruptions, particularly with Linode Kubernetes Engine (LKE) deployments. Our teams are actively working to resolve these issues and restore full service. We appreciate your patience and will share further updates as progress is made.
Posted Mar 20, 2026 - 14:23 UTC

Update

We are still working to resolve the connectivity issue at our Jakarta, ID data center. While most services are recovering, some compute services in Jakarta may still be affected. Due to backend dependencies, there may also be impacts to nearby data centers Singapore Expansion, SP (sg-sin-2) and Melbourne, AU (au-mel). Linode Kubernetes Engine (LKE) in these regions could experience disruptions because of a dependency with Jakarta, ID (id-cgk). We appreciate your patience and will provide further updates as we make progress.
Posted Mar 20, 2026 - 13:31 UTC

Identified

We are continuing to implement a fix for the connectivity issue in our Jakarta, ID data center.
Posted Mar 20, 2026 - 12:57 UTC

Update

Our team has identified the issue affecting connectivity in our Jakarta, ID data center. We are working quickly to implement a fix, and we will provide an update as soon as the solution is in place.
Posted Mar 20, 2026 - 12:11 UTC

Investigating

Our team has identified the issue affecting connectivity in our Jakarta data center. We are working quickly to implement a fix, and we will provide an update as soon as the solution is in place.
Posted Mar 20, 2026 - 11:29 UTC
This incident affected: Regions (ID-CGK (Jakarta)) and Linode Kubernetes Engine (AU-MEL (Melbourne) Linode Kubernetes Engine, SG-SIN-2 (Singapore 2) Linode Kubernetes Engine).