Service Issue - Cloud Manager and API
Incident Report for Linode
Postmortem

At ~1:45PM EDT on Aug 8, 2022, API 4.133.0 was released into production. This release included a change to the way grants were configured to ensure they were not overly broad for security reasons. In the process, this prevented customers from being able to access opened tickets that had already received a response from Support.

Support was able to identify this issue as customers reported it via phones and newly created tickets then escalated the issue to the administrators. A hotfix to address the issue securely was released at ~6:32PM EDT which allowed customers full access to their Support tickets once more.

Additional testing will be implemented for future API releases to ensure this issue does not happen again.

Posted Sep 07, 2022 - 17:20 UTC

Resolved
We haven't observed any additional issues with the Cloud Manager or API, and will now consider this incident resolved. If you continue to experience issues, please contact us at 855-454-6633 (+1-609-380-7100 Intl.), or send an email to support@linode.com for assistance.
Posted Aug 08, 2022 - 23:26 UTC
Monitoring
At this time we have been able to correct the issue affecting the Cloud Manager and API. We will be monitoring this to ensure that the service remains stable. If you are still experiencing issues and unable to open a Support ticket, please call us at 855-454-6633 (+1-609-380-7100 Intl.), or send an email to support@linode.com.
Posted Aug 08, 2022 - 22:50 UTC
Identified
Our team has identified the issue affecting the Cloud Manager and API that is preventing users from accessing open Support tickets. We are working quickly to implement a fix, and we will provide an update as soon as the solution is in place. In the meantime, if you are experiencing an urgent issue and are awaiting a response on an opened ticket, we recommend calling the Linode Support line at:

U.S. 855-454-6633
Global +1-609-380-7100
Posted Aug 08, 2022 - 22:10 UTC
This incident affected: Linode Manager and API.