Connectivity Issue - DNS Resolution
Incident Report for Linode
Postmortem

On July 22, 2022, starting at approximately 11:56 UTC, customers utilizing Linode DNS resolvers in our London data center experienced intermittent timeouts and long-running requests leading to interruptions in domain resolution.

After investigating, our team discovered this was due to a misconfigured service, which was addressed.

Linode DNS resolvers recovered at approximately 12:36 UTC, and the incident was considered resolved as of 12:40 UTC.

Following this incident, our internal workflows and tooling have been updated to better address any similar future issues.

Posted Aug 25, 2022 - 17:41 UTC

Resolved
This incident has been resolved.
Posted Jul 22, 2022 - 13:40 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 22, 2022 - 13:24 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 22, 2022 - 12:56 UTC
Investigating
Our team is investigating an issue affecting our DNS resolvers in our London datacenter. During this time, users may experience an elevated rate of errors, including records not resolving as expected or taking longer times for resolution. We will share additional updates as we have more information.
Posted Jul 22, 2022 - 12:40 UTC
This incident affected: Regions (EU-West (London)).