Service Issue - Block Storage Frankfurt
Incident Report for Linode
Postmortem

On 21 December, 2021 at 15:05 UTC, some of our customers with Block Storage volumes in our Frankfurt data center experienced degraded throughput.

Linode's Incident Response Procedures were immediately engaged, and we identified a combination of underlying configuration issues and hardware failures.

These issues led to the loss of functionality with multiple nodes within our Block Storage cluster during routine maintenance. While the design of our system allows for the loss of multiple nodes without loss of data, this specific failure mode led to performance issues until the misconfiguration issues were resolved.

At 16:00 UTC, Linode solved the underlying issues and customer performance issues were resolved. 

We have completed a review of our internal processes surrounding this event, and steps have been taken to help ensure that this incident does not happen again.

Posted Jan 05, 2022 - 20:23 UTC

Resolved
This incident has been resolved.
Posted Dec 21, 2021 - 18:28 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 21, 2021 - 17:42 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 21, 2021 - 16:12 UTC
Investigating
Our team is investigating an issue affecting the Block Storage service in our Frankfurt data center. During this time, users may experience connection timeouts and errors with this service. We will share additional updates as we have more information.
Posted Dec 21, 2021 - 15:35 UTC
This incident affected: Block Storage (EU-Central (Frankfurt) Block Storage).