Support Phone Outage
Incident Report for Linode
Resolved
No additional issues with our Support phone line have been observed. Please feel free to give us a call if you have any questions or concerns.
Posted 11 months ago. Feb 01, 2017 - 05:08 UTC
Investigating
We are currently experiencing issues with our Support phone line and are currently investigating. If you need assistance from our Support team, please reach out to us via a support ticket or email support@linode.com. We will provide updates as we have more information.
Posted 11 months ago. Feb 01, 2017 - 03:22 UTC